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Introduction 

Your MRI database is a relational database.  A relational database consists of tables, which are the main structure of a 
database. A table is a defined structure containing values (data) in columns (fields), where each set of columns make up 
a row (record).  There are elements of a table like primary and foreign keys, which make each record unique and 
maintain the integrity of your data, and indexes to help the system find and sort the information quickly.  The data fields 
in tables are modified by SQL statements passed from the MRI programs to the database.  

Views are the interface between the user and data that allow data to be presented in usable format for adding and 
updating.  Reports present data stored in the tables.  MRI provides a variety of ways to present the data.  

Today’s seminar will provide you with an introduction on how to present your data on a report using the MRI Report 
Design report writer. 

Capabilities 

Report Design is a comprehensive report writer that includes an extensive range of user interface customization tools to 
simplify report design, increase efficiency and ensure accuracy.  Report Design was designed to meet the needs of those 
clients who want the flexibility and power to create their own custom financial statements, variance reports, rent rolls, 
sales reports, vendor listings, and many other operational reports needed.  For added flexibility, reports created in MRI’s 
ad hoc report writer, Plato, may be modified in Report Design. 

Consider the following key points: 

 Ability to use SQL (Standard Query Language) expressions 

 Exporting to Excel 

 Export to Word 

 Email reports  

 Send reports to PDF, XML, CSV, TXT or HTML files 

 Drill-down capabilities 

 Drag and drop capabilities 

 Standard styling for object uniformity 

 Quick formatting options for numbers and labels 

 Enhanced, professional looking reports 

 Easy graph capabilities 

 Insert company logos and other bit maps 

 Extensive consolidation capabilities 

 Copy and paste features 

 Use of account range groups 

 Archive reports for easy reference 

 Unlimited styles when printing reports 

 Customized run time views 

 Quick page setup capabilities 
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 Design reports that allow information from multiple modules on one report 

 Secure reports 

 MRI provides predefined functions – both general and specific to the property management industry 

 Hide information from printing on the report but can be used in calculations 

 Copy or Delete reports 

 Create reports that can import or export data 

 Create reports that can manipulate data and write to tables in the database using SQL language 

 

Key benefits from these points include: 

 

 All standard MRI reports can be copied and tailored to meet your needs, allowing you to leverage standard MRI 
functionality to meet company specific requirements. 

 All reports can be deployed simultaneously to the MRI Windows and MRI Web environments, minimizing 
development efforts and providing the flexibility to deploy the reports to all MRI users. 

 Reports can be used to perform complex integrations based on the ability to import / export data and write 
data to tables via SQL.  Clients can build their own integrations! For example, MRI developed a FAS to MRI GL 
interface a few years ago that  

o Imports data into a temp table in MRI from FAS 
o Manipulates the data into the MRI required format for the journal entry table 
o Writes the data to the MRI JOURNAL table 

 Reports can have custom views associated with them that allow clients to feed variables to the reports, to 
provide run time alternatives for sorting, filtering, etc. 
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Introduction to Report Design 

Types of Reports 

Financial 

These are reports that are used in conjunction with the Financial Formats, such as Balance Sheets and Income 
Statements.  Financial formats allow you to define the presentation of line item financial data. 
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Non-Financial 

These are reports that do not contain any financial information, such as a Rent Roll or Check Register. 

 
Understanding the Menu Bar 

 File Menu.  Select the File Menu to create a new report, open an existing report, save your report 
format or delete an obsolete report.  Other options allow you to copy a report or a report heading.  
Also, you may use the File Menu to select one of the last four reports that you accessed. 

 Edit Menu.  Select the Edit Menu to access Report Options as well as copy and paste a field or group 
of fields. 

 View Menu.  Select the View Menu to access the Fields and Properties dialog boxes. 

 Options Menu.  Select the Options Menu to specify parameters that will assist you while you are 
designing the report. 

 Window Menu.  The Windows Menu is not used since you can only have one report open at a time. 

 Help Menu.  Select the Help Menu for the Online Help file, which is currently being updated. 
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Understanding the Tool Bar 

 Add a business graph     Add and create calculations 

   Create a label Create a line Create a rectangle 

                       Add a graphic image    

 

Create a new report                 Save       Toggle Fields dialog                                 Toggle Properties dialog 

   Open an existing report 

A Report Definition controls the layout and content of a report. When used in conjunction with a report definition, 
financial formats and run-time parameters may also control aspects of the layout and content of a report. Report Design 
stores report definitions for every report in MRI. To create or copy a report definition for modifications purposes, you 
need to understand the following three design elements: 

 Segments: Sections of a report on which you can place objects to display information. 
 Objects: Items placed on segments to display descriptive text, data from table fields, data from calculation 

fields, or graphics.  
 Properties: Settings for a segment or object based on your preferences or design needs. 

To view the report based on a report definition, you need to run the report. When you run the report, the system uses 
the parameters set on the Run Report view and the report definition to display and format data from your database. 

 
Segments 

A segment represents a section of a report. To display report data on a segment, you must add objects to the segment. 
When you add a segment, the segment consists of one line. However, you can expand the height of any segment to 
create a multi-line segment. 

 

 

Report Design provides different categories of segments so you can divide report data into logical groups that appear in 
a particular order when you run a report. To identify segments in a report definition, you can point to any segment to 
view its description in the lower-left corner of the Report Design view. 
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Note: The appearance and layout of segments in a report definition does not necessarily represent the 
appearance and layout of segments on a generated report. 

Non-Financial and Non-Financial Financial reports will generally consist of one or more of these segments: 

 Report Header Segment.  The segment where the user defines the heading information of each page and the column 
headings for subsequent segments. 

 Primary Segment.  The segment where the user defines the primary or base data to print on the report.  
Minimally, all non-financial reports must have a primary segment. 

 Secondary Segment(s).  The segment where the user defines a related table to print additional data on 
the report.  This segment is used in conjunction with the Primary or another Secondary segment based on 
related table (generally lower in the hierarchy) that can display multiple records for the key field of the 
primary or secondary segment. 

 Total Segment.  The segment where the user defines calculated fields that are used to total data on the 
report. 

 Grand Total Segment.  The segment where the user defines calculated fields that are used to determine 
the final or grand total of report data. 

Financial Segments allow you to present General Ledger financial data on a report.  If you start a report as a 
financial report, the program automatically sets up three financial segments instead of one primary segment.  
Note that GL financial reports use the Entity as the base table. However, this type of report can consolidate 
financials for any reporting hierarchy above Entity including portfolio, owner, property type, region, etc. 

Financial Reports will use the following segment types (the GL-type segments are used in conjunction with the 
Financial Format): 

 Report Header Segment.  The segment where the user defines the heading information of each page and 
the column headings for subsequent segments. 

 GL Title Segment.  The segment where the user specifies the objects that print the information from the 
Line Type of Title. 

 GL Financial Format Segment. The segment where the user specifies the objects that print the 
information from the Line Types of Range and Summarize. 

 GL Total Segment.   The segment where the user specifies the objects that print the information from the 
Line Types of Subtotal and Total. 
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Objects 

An object is an item you can add to a segment to display data or graphics on a generated report. To add one of the 
following objects, click on the appropriate icon, move your mouse to the area on the segment you wish to place the cell, 
hold down the left mouse button and “draw” the cell. Once you release your mouse button, the desired object will be in 
place. 

Note: A report must have segments before it can have objects placed on it.  

Objects that display data appear as cells in Report Design 
 Table field values–Identified as table field objects in Report Design 
 Calculated values–Identified as calculation field objects in Report Design 
 Descriptive text–Identified as label objects in Report Design 

Objects that display graphics appear on segments as one of the following types of graphical elements: 
 

 Bar Graph 

1. Image 

2. Label 

3. Calculation Field 

4. Line 

5. Rectangle 

Symbols and Outlines 

 Arrow.  Standard cursor to give focus to a segment or object. 

 Hand.  Cursor that allows a segment or object to be moved. 

 Two-Way Directional Horizontal Arrow.  Cursor that allows a segment or object with handles to be resized. 

 Two-Way Directional Vertical Arrow.  Cursor that allows a segment to be resized vertically. 
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 Four-Point Pointer.  Cursor that allows a line to be resized. 

 FLD with Swish Marks and Down Arrow.  Field dragged from Segment Fields dialog box is ready to be dropped. 

 FLD with Up Arrow.  Field dragged from Segment Fields dialog box is not ready to be dropped. 

 Object(s) Outlined with Heavy-Lined Border without Handles.  Objects that were lassoed and can be moved 
with the Hand cursor. 

 Segment or Object with Heavy-Lined Border with Handles.  Segments or objects with focus can be resized 
horizontally.  Objects such as graphs and images have more handles and can be resized both vertically and 
horizontally. 

TIP:  Chose a corner handle to resize an object proportionately. 

Copy and Paste 

There are several different ways to copy and paste an object in Report Design. The first way is using the shortcut 
keys (Copy is Ctrl+C and Paste is Ctrl+V). The second way is to select each function from the Edit Menu. 

TIP: PASTE - Shortcut key vs. Edit Menu. When the Edit Menu PASTE function is used for either the shortcut key 
or Edit Menu COPY function, the Edit Menu PASTE function with paste the object(s) at the left-most corner of 
the segment. When the shortcut key for PASTE is used, the Ctrl+V copies the object(s) where the focus is placed. 

If the shortcut keys are used and the paste of the object is placed outside the boundaries of the segment, the 
following message will appear.  To correct, delete the cell(s) and try again. 

 

Properties 

A property is a setting you can define for a segment or object based on your preferences or design needs. To define 
properties for a segment or object, you use the properties dialog box. The properties dialog box displays properties 
specific to the selected segment or object. To view a description of a property, you can click the property name on the 
properties dialog box. 
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Properties for most segments and objects are sorted under tabs on the properties dialog box based on their function. 
For example, properties related to the appearance of a segment or object appears on the Format tab. Some properties 
only appear on the properties dialog box when you select 'Display All Object Properties' on the Options menu. 

Dialog Boxes 

The View Menu contains the commands that enable you to view the Segment Fields dialog and properties dialog 
boxes.  These boxes contain the specific properties and attributes of each cell and segment, allowing the user to 
specify the data cell and how it is to be displayed. 

 Fields dialog.  This option allows you to display the “Segment Fields” dialog box, which is a list of all the 
data fields available to be placed on that segment. These fields can then be “clicked and dragged” onto 
the segment.  You can also display the “Segment Fields” dialog box by clicking the “Toggle Fields” dialog 
icon on the tool bar, right clicking inside the segment to which you want to add a field and selecting “View 
Fields” Dialog, or pressing the F5 key. 

 

TIP:  Make sure the proper segment has focus in order to “drag and drop” a field. 
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Properties Dialog 

This option allows you to display the properties dialog box, which is a list of all the attributes of a specific cell.  
These attributes tell the system what data you would like to place on the report as well as any font or display 
characteristics.  You can also display the properties dialog box by clicking the Toggle Properties Dialog icon on 
the tool bar, right clicking inside any segment, field, or object and clicking View Properties Dialog, or pressing the 
F4 key. 

 

Creating Reports 

You may create a report in one of three ways: create it from “scratch”, copy an existing report and change the 
applicable cells, or open a Plato report.  MRI has approximately 300 reports from which to copy. 

Copying a Report 

The easiest way to create a new report is to copy a MRI report similar to yours.  Follow these simple steps to 
accomplish this task: 

1. Click Copy Report Definition from the File Menu.  Then select Report menu with all current reports 
displays. 

2. Scroll through the list of reports and highlight the report you want to copy. 

3. Select a destination database (if different from the one you are copying from). 

4. Enter a new report name and report description. 

5. Click the Copy Report Definition.  The program will copy the selected report to the new report you 
defined. 
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Copying a Report Header 

If you have a standard report header to use for all your reports or there is something similar in an MRI report, you 
may copy the header from another report. 

1. Click on Copy Report Header from the File Menu.  The Copy Header box appears where you can select the 
database to copy from and the report name you wish to copy. 

2. Scroll through the list of reports and select the report you wish to copy from. 

3. Click on the Segment ID 2000. 

4. Click Copy Header. 
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TIP:  To delete the unwanted fields, simply highlight the cell and click the Delete button. In Report Design, you 
delete one field at a time. 

Creating a New Report 

To create a new report, click the “Create New Report” icon and the Report Options window will appear.  In the Report 
Options view, the following parameters should be determined: 

  

Report Setup tab 

 Name and Description 
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 Application Id 

 Primary Table 

 Financial or Non Financial Report 

 Group folder where this report can be located 

 Report View tab 

 Report’s View for run time options 

 

Page Setup tab 

 

 Paper type and dimensions 

 Paper Orientation 

 Margins 

Default Fonts tab 

 Default fonts by report section 
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Associating a View with a Report 

Each report contains standard options that determine the report output.  Custom options may be added to the report.  
These custom options may include such items as the report period, basis type, report date, consolidated vs. non-
consolidated, sort options or square foot type.  Both custom and standard options are maintained in a view that appears 
when you run the report.  These views are often referred to as “run-time options” and may be defined with the 
ViewDesign tool.  This custom view is then attached to the report through the Report Options window. 

Note: Associating a Report with a Web Activity Group/page is done through Web Design and is done AFTER the report 
has been created.  It can be helpful to add it to View Design and associate it here during testing and then Web Enable 
the View later. 

To select a view and attach it to a report, simply click on the Report Views tab. 
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Here is an example of a report with the default view:

 

Here is an example of a financial report view (MRI_GLRW): 

 

Top half of report 

view is standard. 

Bottom half of 

report may be 

customized. 
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Report Layout 

When designing a report, determine how the report would lay out on a piece of paper.  The Page Setup tab allows for 
quick and easy setup by specifying the paper type, paper width and height, page orientation and margins for the report. 

 

TIP: Paper Width determines the ruler or print area of the report.  For those reports intended to be exported to Excel 
and not meant to be printed in MRI as an MRI report, you can expand the Paper Width to accommodate your needs. 
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Default Fonts 

The Default Fonts tab contains options for each segment type placed on the report. The fonts identified are global 
changes for all the fields defined on that segment. However, the font defined for a field overrides the font specified for 
the segment. 
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After completing the Report Setup, Report View, Page Setup, and Default Fonts tabs, click OK.  A blank report 
displays with a single-line indicating the report’s Primary Segment. 

 

New Report Primary Segment 

Options Menu 

The Options menu allows you to set certain parameters that will assist you while you are designing the report. 

 Display Caption Fields.  This option allows you to see the captions, titles, or cell IDs for fields you add to a 
report.  When you add a label, the caption you type in the Properties dialog box displays.  When you add a 
field to a report from the segment fields dialog box, the segment field title displays.  Calculated fields 
display any text you type in the Cell ID property of the properties dialog box. 

 Display All Objects Attributes.  This option allows you to see all the object attributes of a field in the 
Properties dialog box, including programming attributes. 

 Align to Rule.  This option automatically aligns fields that are placed into a report.  When you place the 
field or move it in the report, Align to Rule forces the field to a preset alignment unit along the ruler of the 
report. 

TIP:  Allow adequate space between cells on the segments, especially if the report is exported to Excel and 
Word. 

 Align Units.  When the Align to Rule option is on, Align Units sets the parameters for the alignment.  The 
possible parameters are 1/16”, 1/8”, ¼” and ½”. 

 Save Settings on Exit.  Save the options you have set so the next time you use Report Design, the selected 
options are saved. 
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Adding Segment Fields 

Segment Fields are fields you add to a report in order for it to return the data for that field at run time.  These 
are a type of calculation field cell. The Segment Fields dialog box shows the base table being used and the 
related.  The related tables are associated to the base table and are higher in hierarchy than the base table. 

The primary table you select when beginning a new report should be on the lowest level needed for that report.  
This is necessary if you use related tables for adding fields to the report.  When you add other table fields, the 
program can only access related tables that are higher in hierarchy than the primary table. 

To add fields to a report, view the Segment Fields dialog box in one of the four following ways:  click the 
Toggle Fields Dialog icon, right mouse click in the segment and select View Fields Dialog, press F5, or select 
Fields Dialog from the View Menu. 

 Click the Display Field ID at the bottom of the dialog 
box if you want the actual Field Ids to display in the 
dialog box. 

 Click the Drag/Drop Field Description at the bottom 
of the dialog box.  This allows you to place the Field 
and Field Description, as a label cell, into the report. 

 Click a field you want and drag it onto the report. 
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Properties of a Cell 

Each segment and object has its own properties. The properties dialog box shows all attributes of that segment 
or object. The attributes for a segment or object may span over one or more tabs.  The description of each tab 
denotes its basic purpose.  For example, the Properties tab is used to define the type, look, and placement of 
the Primary Segment. 

After dragging and dropping fields from the Segment Fields dialog box, you are now able to view or change the 
properties of a cell (form objects such as a label or calculation) by simply placing your mouse anywhere in the 
cell and view the Properties Dialog box in one of four following ways:  click the Toggle Properties Dialog icon, 
right mouse click on the segment or object and select View Properties Dialog, press F4, or select Properties 
Dialog from the View Menu. 

      

TIP:  As the cursor moves over a segment or object, the status bar displays a description. This description is a 
portion of the property, which enables to see where you are in an instant without accessing the dialog box. 

TIP:  To display the definition or cell name of the object, verify that “Display Caption for Fields” is checked in the 
Options Menu.  To display all attributes, verify that “Display All Object Attributes” is checked in the Option 
Menu. 
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Also, the Properties Dialog box is divided into two columns:  Property and Property Value.  By right mouse 
clicking in the Property column, a description of that property will appear. To add or change the value, you 
must click in the Property Value column. 

 

 

Right click on the word 
Caption to display the 
description of the property 

Click in this area to 
change the value. 
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Label 

 

Basic Label Properties – Properties Tab 

 Alignment.  Identifies the placement of the data. Select left, right or center. 

TIP:  Default alignment of an alpha field default is left. Default alignment of a numeric field is right. 

 BackColor.  Displays the Color palette to modify the background color to the cell. 
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 Caption.  Displays the description of the cell to appear on the report 

TIP:  When you see a description surrounded by !{}, such as !{Building} Id, this means that a “swapname” will be 
used. The “SWAPNAME” table is used to substitute, or swap, an alternate term for a standard MRI term.  In this 
example, the word “Building” could be replaced by the word “Property”. 

FontId.  Displays the Font dialog box to modify the default font attributes of the cell, such as font type, style, size, and 
color. 

 

TIP:  It appears that the smallest size font is 8; however, that number can be changed.  To obtain a smaller font 
size, simply type the number in the size field.  For example, type 6. 

 HorzLine and VertLine.  Allows you to put lines around a cell. Select top, bottom or both and left, right, or 
both. 

 HorzLineColor and VertLineColor.  Display the Color palette to modify the line color of the cell. 
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Calculation Field 

 

Basic Calculation Field Properties – Cell Tab 

 CellId.  Identifies the name of this cell so it can be referenced elsewhere. 

 CellType.  Allows you to tell the system the type of field added to the report.  Available cell type options 
include Calculation Field, GL Actual Amount, GL Budget Amounts, and others. 

 Expression.  Allows you to add an expression or calculation to the field. 

 Field.  Displays the field name (TABLENAME.FIELDNAME) of the segment field. 

TIP:  When “Display Caption for Fields” is used, the field appears in the cell as FIELDNAME.TABLENAME. 

 FieldType.  Enables you to define the type of data in the current cell.  Available options are Alpha, Date, 
Memo, Numeric, and Time. 
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Basic Calculation Field Properties – Format Tab 

 

 

 Alignment.  Identifies the placement of the data. Select left, right or center. 

 BackColor.  Displays the Color palette to modify the background color to the cell. 

 DisplayFormat.  Identifies a predefined format of the data.  Currently, there are several formats from which 
you can choose to customize your report, such as Account Number, Phone, and Zip Code. 

 FontId.  Displays the Font dialog box to modify the default font attributes of the cell, such as font type, style, 
size, and color. 

 HorzLine and VertLine.  Allows you to put lines around a cell. Select top, bottom or both and left, right, or 
both. 

 HorzLineColor and VertLineColor.  Display the Color palette to modify the line color of the cell. 

 Precision.  Allows you to change the number of decimals places in a numerical value. 

 ZeroSpace. –If Yes, will leave the cell blank if the amount is zero. If Default, the segment ZeroSpace property 
will be used. 
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Basic Calculation Field Properties – Options Tab 

 

 Hide.  Allows you to not show a cell value on the printed report. For example, you may choose to hide a 
cell because the value is required for a calculation but it is not necessary to display on the report. 

TIP:  Another example of a hidden cell is a display message, used to denote the printing progress of report. 
When a cell is identified with a CellId of DISPLAYMSG, the field or expression for which it is identified will display 
while the report is processing. 

 MemoCell.-When True, the cell allows multiline text capability. To place maximum lines, refer to the 
property MemoLineLimit. 

 MemoLineLimit.- For one-line segments, a non-zero values specifies the maximum lines that will print. A 0 
indicates no limit. For multi-line segments, the number of lines printed is determined by the height of the 
memo cell. 

 SubstituteCell. – Id of the cell to print if the SubstituteExp evaluates to true. This enables the use of 
different field types, fonts, display formats based on some condition at runtime. 

 SubstituteExp.-If the expression evaluates to true, the contents of cell identified in by SubstituteCell is 
printed. This enables the use of the different field types, fonts, display formats based on some condition 
at runtime. 

 RecapId/RecapRowId.  Allows you to Recap totals to a Recap Segment. 
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Creating Financial Reports 

Opening a Financial Report  

Now let’s open up a Financial Report definition. From the File Menu, select Open Report Definition.  Choose 
MRI_CMPINC and click Select. 

 

 

In a Non-Financial report, the Primary Segment runs a query on your MRI Database and pulls corresponding 
data until it has gone through all the records of the corresponding table. 

In a Financial Report, Report Design does not operate in quite the same way.  Instead, the GL Financial 
Format segment runs down each row on a financial format pulling data from every line that returns non-
zero amounts. 
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Creating New Financial Reports  

There are three detail segments that comprise a financial report – GL Title segment, GL Financial segment and GL Total 
segment. 

When the GL Financial segment uses such CellTypes as GL Actual Amount and GL Budget Amount, a new tab appears. 
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Financial Reports will use the following segment types (the GL-type segments are used in conjunction with the 
Financial Format): 

 Report Header Segment.  The segment where the user defines the heading information of each page 
and the column headings for subsequent segments. 

 GL Title Segment.  The segment where the user specifies the objects that print the information from 
the Line Type of Title and Blank. 

 GL Financial Format Segment. The segment where the user specifies the objects that print the 
information from the Line Types of Range and Summarize. 

 Appear in reports based on financial formats 

 Appear in the body of a generated report after the page header 

 Display information based on a financial format you select at run time 

 GL Total Segment.  The segment where the user specifies the objects that print the information from 
the Line Types of Subtotal and Total. 
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Basic Calculation Field Properties – GL Tab 

 NumPd.  Determines how many periods of data to retrieve for the type of cell identified (Actual, 
Budget, or either).  Values for NumPd are 1-12, 24, YTD.  If NumPd is left blank, the system assumes 1. 

 SelPd.  Specifies what period to use to retrieve data for the type of cell identified (Actual, Budget, or 
either). Values for SelPd: 

 F#.  Fixed Period, where # is 1-12.  

 O#.  Offset Period, where # is the period number to be subtracted from the selected period.  
If the report period were 06/14, O2 would specify 04/14.  You can also specify a negative 
number to go forward a number of periods. If the report period were 06/14, O-3 would 
gather data for 09/14. 

 PY#.  Previous Year, where # is the number of previous years.  If the report period were 
06/14, PY1 would gather data for 12/13.  PY-1 will return 12/15. 

TIP:  All values must be typed in upper case. If YTD is specified as “ytd”, an incorrect value may be 
returned.  SelPd is the ending period.  For example, if your report period is December and you specify 
NumPd=3 and SelPd=O3, the system will gather data for July – September.  You can also combine the 
SelPd values.  For example, you can enter a SelPd of PY1F3. 
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To change a monthly report into a quarterly report, make the following change: 

 

Example of GL Title Segment 

The GL Title segment displays financial format line items with a line type of 'Title' and 'Blank'. 
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Displaying Titles Based on Financial Formats 

If you are designing a report to be used in conjunction with a financial format, you can display report section titles using 
the following design elements: 

 GL Title segment—Displays financial format line items with a line type of 'Title.' 

 GLRWTITLE{} function—Displays each section title specified in a financial format. 

To display titles based on a financial format: 

 Add a calculation field to the GL Title segment by clicking the Calculation button, and then dragging across the area 
of the segment where you want the title to appear. 

 Click the calculation field, and then on the View menu, click Properties Dialog to display the Calculation Field 
Properties dialog box. 

 In the field for the Expression property on the Cell tab, create an expression using the GLRWTITLE{} function in the 
GL Financial Report Functions folder. 

 Format, size, or move the calculation field as needed. 
 On the File menu, click Save Report Definition. 
 Run the report to view the titles. 
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Example of GL Financial Format Segment 

The GL Financial Format segment displays financial format line items with a line type of 'Range' or 'Summarize.' 

 

Displaying GL Account Information Based on Financial Formats 

If you are designing a report to be used in conjunction with a financial format, you can display certain account 
information using the following design elements: 

 GL Financial Format segment—Displays financial format line items with a line type of 'Range' or 
'Summarize.' 

 Calculation fields with GL cell types—Display actual or budgeted account information from the account 
range defined in the financial format. The system selects account information from the GL Summary 
(GLSUM) table or the Budget (BUDGETS) table depending on the cell type you select. 

 Calculation fields with GL functions—Display additional account information, such as account name or 
number, using GL Financial Report functions. 

1. Add a calculation field to the GL Financial Format segment by clicking the Calculation button, and then dragging 
across the area of the segment where you want the account information to appear. 

2. Click the calculation field, and then on the View menu, click Properties Dialog to display the Calculation Field 
Properties dialog box. 
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3. Click the Cell tab. 
4. In the field for the CellId property, type a unique name to identify the calculation field. 
5. To display— 

 Actual amounts  

1. In the field for the CellType property, select GL Actual Amount. 
2. In the field for the FieldType property, select Numeric. 

 
 Budget amounts  

1. In the field for the CellType property, select GL Budget Amount. 
2. In the field for the FieldType property, select Numeric. 

 
 Actual amounts or budget amounts if no actual amounts exist  

1. In the field for the CellType property, select GL Actual or Budget. 
2. In the field for the FieldType property, select Numeric.  

 
 Variances between actual and budget amounts  

1. In the field for the CellType property, select GL Variance Calculation. 
2. In the field for the Expression property, create an expression, such as CELL{cellid}-CELL{cellid} to 

display the difference between two balances. 
3. In the field for the FieldType property, select Numeric. 

 
 Budget notes  

1. In the field for the CellType property, select Budget Note. 
2. In the field for the FieldType property, select Numeric. 

 
 Other account information, such as the account name or number  

1. In the field for the CellType property, select Calculation. 
2. In the field for the Expression property, create an expression using a function in the GL Financial 

Report folder, such as ACCTNAME{} to display the account name or ACCTNUM{} to display the 
account number. 

6. To limit report results based on any other criteria, such as a period, define a filter for the calculation field using 
properties on the GL tab.  

Note: To apply the same criteria to all fields on the GL Financial Format segment, you can define a filter for the segment. 

7. Format, size, or move the calculation field as needed. 
8. On the File menu, click Save Report Definition. 
9. Run the report to view the account information 
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Example of GL Total Segment 

The GL Total segment displays financial format line items with a line type of 'Subtotal' or 'Total.' 

 

Displaying Totals Based on Financial Formats 

If you are designing a report to be used in conjunction with a financial format, you can display totals for a column using 
the following design elements: 

 GL Total segment—Displays financial format line items with a line type of 'Subtotal' or 'Total.' 

 GLTOT{cellid} function—Enables you to specify the field on the report for which you want to display a total. 

To display totals based on a financial format: 

1. Add a calculation field to the GL Total segment by clicking the Calculation button, and then dragging across the 
area of the segment where you want the total to appear. 

2. Click the calculation field, and then on the View menu, click Properties Dialog to display the Calculation Field 
Properties dialog box. 
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3. In the field for the Expression property on the Cell tab, create an expression using the GLTOT{} function in the GL 
Financial Report Functions folder.  

Example  
To display totals for data that displays in a field with a cell ID of 'CURMON,' use the following expression: 
 GLTOT{CURMON} 

4. In the field for the FieldType property, select Numeric. 
5. Format, size, or move the calculation field as needed. 
6. On the File menu, click Save Report Definition. 

Creating a New Financial Format 

When creating a financial report it is important to remember that the financial format defines the rows in a 
report while the Report Design defines the columns.  Only financial reports use financial formats. 

 The financial format screen: 

  

In the financial format you specify which chart of accounts and which individual accounts within that chart that you want 
to use in the report.  The ledger code field specifies which chart of accounts is being used in the format. 

The Balance Sheet box is used to indicate if you want the system to calculate Retained Earnings.  The box is typically 
checked if you are running a balance sheet.  If the box is checked the report defaults to pulling in ending balances for the 
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accounts specified in the ranges for the runtime period.  Also the report will calculate retained earnings by summing all 
balances for the current fiscal year for accounts defined as income statement accounts in the chart and placing that 
summed amount in the defined retained earnings account. 

If the box is unchecked the report defaults to pulling in account activity for the accounts specified in the ranges for the 
runtime period.  You can also summarize amounts by major accounts by selecting the Summary option on the runtime 
options for the income statement report.  

In financial formats the Reverse Amount option, controls the math on the report and the Debit/Credit column controls 
the signage. 

 

 

RANGE – Used to define one or more ranges of accounts to use in a section of the report.  The system displays the name 
of each account number in the range that has a balance. 

SUMMARIZE – Used to group a range of like accounts into one summarized line.  The system only prints one 
summarized line using the description in the title field. 

SUBTOTAL – Used to sum the balances of all preceding Range and Summarize lines that are not included in a previous 
Subtotal.  The system assigns a Sub Total Id number which is used to specify totals elsewhere in the report. 



Advanced Report Design - RM 
 

 
 

40 
                                                                 October 19-22, 2014 | New Orleans Marriott | New 

Orleans, LA 

TITLE – Used to label a section of the report. 

TOTAL – Used to identify a line in the report as a total of specified subtotals. 

BLANK – Used to create a blank line on the report for spacing purposes. 

 

B – The line uses the account balance at the beginning of the period rather than the default for the report type, which is 
ending balance for Balance Sheet and activity for the period for Income Statement.  Can be used on Range & Summary 
type lines. 

E - The line uses the account balance at the ending of the period rather than the default for the report type, which is 
activity for the period for Income Statement.  Can be used on Range & Summary type lines. 

^ - The line multiplies the dollar and percent variances on a comparative report by negative one.  Can be used on Range, 
Summarize, Subtotal & Total lines.  

R – The line multiplies the amount by minus one.  Can be used on Range and Summarize lines.   

S – Suppresses the printing of the line completely. 
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= - Prints a double line below the total or subtotal in the report.  Can be used for Total and Subtotal lines 

Z – Suppresses the printing of the line if the amount is zero.  Used in Subtotal lines. 

U – Suppresses the printing of the underline on Subtotal or Total lines. 

1 – Used to identify which subtotal is defined as the 100% line.  Used in reports where the SUB100 function is being used 
to calculate percentages for each line of the report.  To calculate the percentages, the system divides each balance, 
subtotal, or total by the total or subtotal specified as the 100% line.  

P – Forces the section title to print on a new page. 

S – Suppresses the test in the Title field on a title line if the related subtotal equals zero.  
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Individual accounts or account groups can be selected or excluded on either a range or summary line type.  
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Creating a Residential Management Report  

This process is very similar to creating a financial report with the exception that the segment names are slightly 
different.  For non-financial reports, you will typically have, at a minimum, a page header and a primary segment which 
the main output of the report is based on.  For instance, if we were creating a custom Resident Contact Listing, The 
primary segment is based on the RMPROP table and a secondary segment based on the NAME table. 

 

The page header will hold all of the header details including the report title, date, page numbers, and column headers.  
The primary segment includes the fields or cells. In our example the primary segment contains the RMPROPID and 
PROPNAME fields.   

To get the property to print at the top of each page you would need to do a couple of things. 

 Name the Cells that would be referenced.   
 Add a calc cell on the page header that references those Cells within the Expression: TRIM{CELL{RMPROPID}} - 

CELL{PROPNAME}  
 Insert a Segment Header (not to be confused with a Page Header) based on the RMPROPID. 

 
 
Select the Field Value -> Select Field -> RMPROPID -> Select 
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Screen will look like this.  Press the Add Segment to move it into the Segment Graphic section. 
 

 
 



Advanced Report Design - RM 
 

 
 

45 
                                                                 October 19-22, 2014 | New Orleans Marriott | New 

Orleans, LA 

 
  
Once satisfied with the placement, Press OK 
Now have a new header segment added to the report. 
 

 
 
Within the properties – Options tab of this segment you would add a page break. 
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Note: Whenever you insert a header or Total Segment the Order is assumed.  However, the process will add an 
extra comma at the end that needs to be removed or else you will get an error when running the report. 
 

 

In our example there is a secondary segment based on the NAME table. 

To add a secondary table to a report, you right click your mouse on the primary segment.   
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This menu allows you to do a number of things including “Inserting a Secondary Segment”.  A few other options 
worth highlighting here include: 

 Insert Segment Header – allows you to insert a header above a secondary segment 

 Insert Segment Total – allows you to insert a total segment for a secondary segment 

 Report Expressions – allows you to find references to segments, cells, expressions, etc. 

 View Properties – displays properties for the selected object 

Upon choosing “Insert Secondary Segment”, you must select a table to base the segment on.  MRI includes some 
unique database management properties that allow it to automatically display all tables related to the primary table 
for the report.  This is a HUGE time saver as it eliminates the need for users to manually join the secondary table to 
the primary table. You do have the option to “Show all tables”.  If you choose a table that doesn’t have a direct 
relationship with the primary table, you must then create a manual “join” between the two tables to establish the 
appropriate relationship. 
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Once the segment is added various fields can then be dropped onto this segment from the Fields Dialog. 

 

Notice that some of the fields were dropped outside the Print parameters and hidden. This is valuable 
for collecting information to use elsewhere.  The FIRSTNAME and LASTNAME fields are an example of 
this. Then in a calculation cell the 2 fields are concatenated.   

Name Cell 
Expression:  CELL{LASTNAME}, CELL{FIRSTNAME} 

Resident id Cell 
Expression: CELL{RMBLDGID}-CELL{UNITID}-CELL{RMLEASE} 
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The CodeDesc from the CODELIST table is added for the Status.  This field needs a special JOIN to pull 
the correct description. 

  

  

Under the Options tab the DefaultJoin property is STATUS for the STATUS field from the NAME table. 
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If we run the report now, it looks as follows. 

 

 

The next thing that would be helpful is to add some counters. 

 Add a Calculation Field and name it CURCOUNT.  This field will flag the Name records with a Current Status. It 
will have a conditional Expression value of 1.   Don’t forget to make sure it is a Numeric Field. 

 

 Add a Calculation Field and name it COUNTER.  This field will be for all Name records regardless of the status. It 
will have an Expression value of 1 

The next step is to add a Total Segment to accumulate these counters.  Go back up to the Primary Segment that is based 
on RMPROP -> Right mouse click -> Insert Segment Total 
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Go through the same steps as creating a segment header by Select Field -> Choose RMPROPID  -> Add Segment -> 
Position correctly -> OK 

Then add the labels and the calculation cells. 

 

Now the report looks like this. 
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Since we would like this to be more flexible we would need to add “run-time” options.  This is done through 
View Design for Windows and Web Design for the Web. 

Note:  As a common practice I often start with the View Design so I can see the field names within the Report 
Design.  Once I am satisfied with the view it can be Web-enabled easily. 

The first step is to copy a Sub View from an existing Run-time view. 
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It is helpful to name the Sub View the same name as the Report. 

Notice that all the Windows Run-time Sub Views are associated with a table named MRIRPTS. 

Open the View and make changes. 

 

In this example I reformatted the checkbox and changed its name to INCLCORES 

Next Link this view to the Report. 

Within Report Design.  Edit -> Report Options -> Report View 
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This will associate the view with the report. 

 

Next you will need to add the filter to the NAME segment to restrict the selection if Co-Residents are not selected. 
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Notice that the INCLCORES is not in the Run time List. 

Get your SQL hats on and notice that we are using an IF{} function in the WHERE clause of the NAME Segment. 

 

The last step would be to Web enable the report through Web Design. 
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Complete the following steps create a custom report page that contains report parameters: 

1. Select File>New Activity Group.  

The New Activity Group dialog box appears. 

2. Click Copy a page from another group, and click OK. 

 

The Copy Page dialog box appears. 

3. Check the Windows Views checkbox. 
4. Select the view, and click Copy. 
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5. Add the DIV and spacers to the page. 
6. Highlight all objects on the page and click Apply Style from the properties dialog box. 

 

 

7. Open the properties dialog box for the form and click on the Properties tab. 
8. Select Yes for the value of the ReportOption property value. 

 

Note: Setting the Report Option property to yes is required when creating custom report 

option pages. 

 

Complete the following steps to make a report available to Web users: 

 Select File>Web Reports to display the Web Reports dialog box (see below). 

 On the left side of the dialog box, open the All Reports folder.  

 The reports in the folder appear on the right side of the dialog box.  

 Select the check box next to the IUC_RMRESCON report ID to make the report available in MRI for the Web. 
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 Right-click the report to display the shortcut menu, and then click Edit. 

 Select the activity group that has the custom web report option (see below). 

 

 Click OK. 

 Click Save. 
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While there are certainly a number of additional enhancements that could be made to this report to 
improve its appearance, in just a few minutes, you can produce meaningful outputs from MRI using the 
Report Design tool. 
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NOW, Creating an Advanced Report for Residential Management  

Session Description:  

Builds on the concepts learned in Introduction to Report Design. Discover how to use your knowledge of SQL to create 
more complex reports by using the SQL features o f the report writer. Discover common report design functions as well 
as how to use “IF” statements to create skip expressions or tests.  

Learning Outcomes:  

Gain a working understanding of the Dialog Box in report writer and develop a working knowledge of how to use the 
Expression Builder along with common functions built into MRI. Learn how to sue transact SQL and IF statements to 
create more complex report. Learn how to debug reports. 

Per-Requisites: 

Introduction to Report Design or practical use or experience with basic SQL queries and Report Writer knowledge. 
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A few tables in RM 

NAME, Resident Names 

Fields: NAMEID, RMPROPID, RMBLDGID, UNITID,RMLEASE 

Used for: Name Id, RM Property Id, RM Building Id, Unit Id, RM Lease Number, First Name, Last Name, NameGroup 

 

RMLEASE, Residential Leases: 

Fields:  RMPROPID, RMBLDGID, UNITID,RMLEASE 

Used for: Occupy Date, Expiration Date, Vacate Date, Current Term Start Date 

 

RMRECC, RM Recurring Charges: 

Fields: RMPROPID, RMBLDGID, UNITID,RMLEASE 

Used for: Charge Codes, Effective Dates, Amounts 

 

RMLEDG, RM Ledger: 

Fields: NAMEID, RMPROPID, TRANID 

Used for: Transaction Date, Charge Code, Source Code, Transaction Description, Transaction Amount, Open Amount, GL 
Reference, RM Batch Id 
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Now let’s talk about finding records when you have only the NAMEID or the RMPROPID, RMBLDGID, UNITID, and 
RMLEASE. 

You can certainly find the NAMEID first and then use that value to retrieve the information you’re looking for OR you can 
join the tables. 

 With an INNER JOIN, only matching records from both tables will be returned. 

 With a LEFT JOIN, all records from the first table are returned, even if there’s no matching record 
in the second table. 

 Use a LEFT JOIN if the foreign key fields might be null. 

Inner Join to RMRECC: 

select rmrecc.* from name(nolock), rmrecc(nolock) where name.rmpropid=rmrecc.rmpropid and 
name.rmbldgid=rmrecc.rmbldgid and name.unitid=rmrecc.unitid and name.rmlease=rmrecc.rmlease and 
name.lastname='Russell' 

Left Joins to RMRECC: 

select rmrecc.* from name(nolock) left join rmrecc on  name.rmpropid=rmrecc.rmpropid and 
name.rmbldgid=rmrecc.rmbldgid and name.unitid=rmrecc.unitid and name.rmlease=rmrecc.rmlease where 
name.lastname='Russell' 

select rmrecc.* from name(nolock) left join rmrecc on  name.rmpropid=rmrecc.rmpropid and 
name.rmbldgid=rmrecc.rmbldgid and name.unitid=rmrecc.unitid and name.rmlease=rmrecc.rmlease where 
name.nameid='HO00000058' 

 

Inner Join to RMLEASE: 

select rmlease.* from name(nolock), rmlease(nolock) where name.rmpropid=rmlease.rmpropid and 
name.rmbldgid=rmlease.rmbldgid and name.unitid=rmlease.unitid and name.rmlease=rmlease.rmlease and 
name.lastname='Russell' 

Left Joins to RMLEASE: 

select name.nameid, name.rmbldgid, name.unitid, rmledg.* from name(nolock) left join rmledg on  
name.nameid=rmledg.nameid and name.rmpropid=rmledg.rmpropid where name.lastname='Russell' and 
trandate>='12/31/07' 
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From the SQL II training:  

Save Time Typing With A Pre-built RM Join Clause 

Writing queries in RM frequently requires joining two or more tables based on 
RMPROPID/RMBLDGID/UNITID/RMLEASE.  Save time by keeping this bit of text around somewhere: 

A.RMPROPID=B.RMPROPID AND A.RMBLDGID=B.RMBLDGID AND A.UNITID=B.UNITID AND 
A.RMLEASE=B.RMLEASE 

Now any time you need to join two tables, just use the aliases A and B, and you can paste in your pre-built 
join expression: 

SELECT * FROM RMRECC A INNER JOIN RMLEASE B ON A.RMPROPID=B.RMPROPID AND 
A.RMBLDGID=B.RMBLDGID AND A.UNITID=B.UNITID AND A.RMLEASE=B.RMLEASE 

This is much easier than: 

SELECT * FROM RMRECC INNER JOIN RMLEASE ON 

RMRECC.RMPROPID=RMLEASE.RMPROPID AND RMRECC.RMBLDGID=RMLEASE.RMBLDGID AND 
RMRECC.UNITID=RMLEASE.UNITID AND RMRECC.RMLEASE=RMLEASE.RMLEASE 
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Create a report that calculates Court Fees for residents with a Late Charge and puts those charges into an open batch. 

To accomplish this, a new batch needs to be created, residents that meet certain criteria are evaluated, transactions are 
inserted and updated while the TRANID is automatically updated,  and the batch is ready to be posted. 

Tips:  

 Determine how you want to run the report 

 Whenever possible, start with an existing report 

 Build a little at a time; save often; run often 

 Make frequent backups of the report 

 Keep components separate for troubleshooting purposes 

 Format the report last 
 

To run this report by an individual resident or by the property, select the NAME Table as the Primary Table.  

The primary table determines the hierarchy in the Selection Criteria. The primary table you select when beginning a new 
report should be on the lowest level needed for that report.  This is necessary if you use related tables for adding fields 
to the report.  When you add other table fields, the program can only access related tables that are higher in hierarchy 
than the primary table. 

The conditions are that the resident records being evaluated are just Resident types and the status is current.  

Based on the number of residents in the Unit, the report needs to calculate a Court Fee of $28 for the primary resident, 
plus $5 per other residents. 

Then, add the records to the new RM Batch that was created, updating the appropriate amount fields so you can run 
Print Open Batch Listing and/or Post the Batch. 

The following print screens show the steps to create this type of report. 
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Open Report Design and Define a New Report. 

 

 

Tip:  When developing a report, I always assign the prefix of DEV_ so it’s not ever confused with the Production version. 
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Drag fields from the NAME or associated Tables to the Primary Segment.  

Save. 

 

Now, let’s add the conditions. 

 

SQL Tab 
Each segment and object has “properties.” The properties dialog box shows all attributes for that segment or object and 
may span over one or more tabs. The description of each tab denotes its basic purpose. For example, the SQL tab is used 
to set conditional parameters. 
 
When you double click on the Property Value section of certain properties, such as 
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‘Where’ and ‘Order’, the Expressions dialog box appears. 
 
Expression Dialog Box 
The left side of the Expressions dialog box shows system-defined run-time variables and cells that you assigned a ‘CellId’ 
on the designated segment. The right side of the Expressions dialog box shows all MRI-defined functions cataloged by 
topic. The Expression Property Value is where you construct the expression statement. 
 
TIP: When creating expressions, syntax is critical. Characters to understand: 

 Parenthesis ( ). Used for arithmetic expressions when order of operation is important. 

 Braces { }. Used to denote a function. 

 Brackets [ ]. Used to denote a variable name. 
 
Hard Coding vs. Variable Conditions 
 
A hardcoded condition is a static condition – this value will not change based on how you run the report. 
 
In our report, our “static” conditions are defined in the “Where” Property: 
 
NAME.STATUS='C' AND NAME.TYPE='R' 
 

 
 
Run the report to make sure it runs and it’s what you are expecting. 
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Report Design creates its own SQL statement that you can manipulate, add to, or delete. 
 
To better understand how you created your report what data is being retrieved, you can set this feature on each 
segment. You have to go to the segment properties, select the Options tab, and turn DEBUG on. 
 
Upon running the report, you will see the SQL statement it creates. 
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Cut and paste this into MRIQRY to see the results: 
 

 
 
If there are no other conditions in the report, such as Skip or Hide Expressions, this should match the values that appear 
on the report.  
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To make these dynamic conditions, we need to add runtime options to make the report more flexible. 
 
Add a runtime option for the Name Status.  
 

 
 
SELECT * FROM CODELIST(NOLOCK) WHERE CODETYPE='NAMESTATUS' 
 
Tip: To determine where these values are derived, use Database Design or run the report MRI_TABLE. 
 

 
 
SQL:SELECT CODEVAL, CODEDESC FROM CODELIST(NOLOCK) WHERE CODETYPE ='NAMESTATUS' ORDER BY CODEVAL 
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Attach the view to the report to confirm its gathering the correct information. Set the Default to “C” for Current 
Resident status.  Now update the report to include a variable condition. 
 

 
 
Using Variable Names 
Variable Names enable you to identify object(s) when you want to filter information. The example below is using a 
Variable Name in a ‘Where’ clause. 
 
To a add a Variable Name to a ‘Where’ Clause: 
 
1. Open the Properties dialog box for the Primary Segment. 
2. Click on the SQL tab. 
3. Highlight the ‘Where’ property and double-click in the Property Value field to 
view the Expressions dialog box. 
4. Type the ‘Where’ clause. Our expression will include the run-time Variable Name 
created in our sub-view for this report. 
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TIP: Null vs. Blank. ‘Null’ describes the raw data and ‘Blank’ describes the field value 
retrieved from a cell. If you reference the data, you want to look for a null value. If you 
reference a field on the report, you want to look for a blank value. 
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To confirm, turn on Debug and run the report and change the selection. 
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Tip: 
 
If you receive this message, Adding to Queue and the MRI Report Manager, this means that there is a Debug statement 
that needs to be acknowledged.  Find the Debug Message, click Ok, and the system will continue processing.  
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Now, we’ll amp it up one more time to further refine the condition. 
 
Add an All, Include, or Exclude component. 
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Update the Where in the report to include an “IF” statement: 
 

 
 
IF{[STATUSSEL]=INC,NAME.STATUS IN SQLLIST{[STATUS]}, 
IF{[STATUSSEL]=EXC,NAME.STATUS NOT IN SQLLIST{[STATUS]},1=1}}  
AND NAME.TYPE='R' 
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Now, create a Segment Header that will display just once for the report. 
 
The reason for only on Segment Header is that this is where our logic for creating the new batch record will reside. 
 

 
 
Create a cell that will retrieve and add “1” to the last number used for the RM Batch Id, which is stored in the MRISEQ, 
MRI Sequence Numbers Table. 
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IF{[UPDATE]=Y,SQL{SELECT LASTUSED+1 FROM MRISEQ(NOLOCK) WHERE SEQID='RMBATCH'},} 
 
With this calculation, add a runtime option for Update.  
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Tip: Also when developing reports, highlight certain segments or cells so they’re easier to find.  
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Next, format the RM Batch Id. 
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Now that you have the next RM Batch Id, the table needs to be updated. 
 

 
 
IF{[UPDATE]=Y,SQL{UPDATE MRISEQ SET  LASTUSED='CELL{LASTUSED}' WHERE SEQID='RMBATCH'},} 
 
 
The last cell we’ll create in the Segment Header is a calculation that will update the RM Batch with information gathered 
so far. 
 

 
 
IF{[UPDATE]=Y,UPDATETABLE{I,RMBTCH,,RMBATCHID='CELL{RMBATCHID}',TYPE='N',STATUS='O',BATCHDATE='[REPORT
DATE]',DESCRPTN='Summons',CONTENT='N',SITEID=NULL,CRCTRL=0,CRRESCTRL=0,CRSECCTRL=0,CRMSCTRL=0,NSFCTRL
=0,NSFRESCTRL=0, 
NSFSECCTRL=0,NSFMSCTRL=0,CRRESINPUT=0,CRSECINPUT=0,CRMSINPUT=0, 
NSFRESINPUT=0,NSFSECINPUT=0,NSFMSINPUT=0,CHARGES=0,REFUNDS=0,SECREF=0, 
SECAPP=0,SECFF=0,SECINT=0,SECADJ=0},} 
 
 
Based on the values that used, create another variable for the “Report Date”.  
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Create a calculation that will count the number of transactions in the Resident Ledger Table (RMLEDG) where the Charge 
Code “LAT” is used for the period we designate at runtime.  
 
Add another variable on the runtime for “Period”.  Create a lookup on Charge Code instead of hard coding the value. 
 

 
 
SQL{SELECT COUNT(*) FROM RMLEDG(NOLOCK) WHERE NAMEID='CELL{NAMEID}' AND CHGCODE='LAT' AND 
PERIOD='[PERIOD]'} 
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Create a calculation that will sum the Open Amount for that Resident based on the period specified at runtime. 
 

 
 
SQL{SELECT SUM(RMLEDG.OPENAMT) FROM RMLEDG(NOLOCK) WHERE NAMEID='CELL{NAMEID}' AND 
PERIOD<='[PERIOD]'} 
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These two calculations will be used in a SkipExpr to further refine the records we want to include on the report.  
 
We only want to see Residents who have a count of Late Charges that are greater than zero AND an Open Amount 
greater than $100.  If they don’t meet these criteria, skip that record. 
 

 
 
Note: The limit could also be defined as a runtime option. 
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There is a difference in the HideExpr: 
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Note: When first testing the report, select to Include one or two Properties. Save the “All” selection until the report is 
complete. 
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Now we’ll add a calculation that counts the Residents associated with the NAMEGROUP Id. 

 
 
SQL{SELECT COUNT(*) FROM NAME(NOLOCK) WHERE NAMEGROUP='CELL{NAMEGROUP}'} 
 
Based on the number of Residents calculated, we’ll determine the Court Fee. This particular fee is $28 for the first 
Resident and then $5 for all others. 
 

 
 
CALC{28+(CALC{(CELL{CNTRES}-1)*5})} 
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Advanced Report Design - RM 
 

 
 

98 
                                                                 October 19-22, 2014 | New Orleans Marriott | New 

Orleans, LA 

 
 
 

 
 
IF{[UPDATE]=Y,1+PRVCELL{COUNTER},} 
 
This is to have a sequential number for our transactions.  
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If I didn’t care about sequential sequencing, I could have used the COUNTER{} function. 
 

 
 
COUNTER{} 
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Tip: Highlight individual cells for several reasons: stand out, remind you to remove, special function such as insert, 
update, or delete, etc. 
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Because of the SKIPEXPR, the count may not be sequential. 
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Now, we’ll create a Secondary Segment which will contain our Insert and Update calculations.  
 
This type of segment does not need a Table Name identified. Select No Table. 
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IF{[UPDATE]=Y,AUTONUM{RMLEDG,Y,10},} 
 
Since only one AUTONUM function can be used in the report, the decision was made that the RMBATCH Id would be 
manually incremented, as I wanted the TRANID to use this function. 
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This cell inserts each record into the RMLEDG Table. 
 
IF{[UPDATE]=Y,SQL{INSERT INTO RMLEDG 
(TRANID,RMPROPID,NAMEID,TRANDATE,CHGCODE,SRCCODE,CASHTYPE,DESCRPTN,TRANAMT,OPENAMT,CHKDESC,RMB
ATCHID,REFNMBR,ADJCODE,RMRTAXID,RTAXAMT,INVOICE,PERIOD,GLREF,BANKID,MEMOFLAG,POTFLAG,NAMEGROUP,
POSTED,PAYTYPE,ADDLDESC,MOVEND,TRANSMIT,TRANSMITDATE,ADJPERIOD,USERID,PROGNAME,APPLYFLAG,SODAFL
AG,STORAGEID,BANKACCOUNTTYPE,ERRORMESSAGE,EFTTRANSACTIONID,ROUTINGNUMBER,ACCTNUMBER,MICR,ACHC
HKTYPE,SFEEAMT,CFEEAMT,RNTPAYMENTREF) VALUES 
('CELL{TRANID}','CELL{RMPROPID}','CELL{NAMEID}','[REPORTDATE]','CF','CH',NULL,'Summons Court 
Fee',CELL{AMOUNT},CELL{AMOUNT},NULL,'CELL{RMBATCHID}',NULL,NULL,NULL,0,NULL,'[PERIOD]',NULL,NULL,NULL,NU
LL,'CELL{NAMEGROUP}','N',NULL,NULL,NULL,NULL,NULL,NULL,'USERID{}','CHARGE.W',NULL,NULL,NULL,NULL,NULL,NULL
,NULL,NULL,NULL,NULL,NULL,NULL,NULL)},} 
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Tip:  
 

 
Export to Excel: 

 
Saved a .CSV file.  
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Open with Notepad:  

 
Exclude all the commas at the end: 
 
TRANID,RMPROPID,NAMEID,TRANDATE,CHGCODE,SRCCODE,CASHTYPE,DESCRPTN,TRANAMT,OPENAMT,CHKDESC,RMB
ATCHID,REFNMBR,ADJCODE,RMRTAXID,RTAXAMT,INVOICE,PERIOD,GLREF,BANKID,MEMOFLAG,POTFLAG,NAMEGROUP,
POSTED,PAYTYPE,ADDLDESC,MOVEND,TRANSMIT,TRANSMITDATE,ADJPERIOD,USERID,PROGNAME,APPLYFLAG,SODAFL
AG,STORAGEID,BANKACCOUNTTYPE,ERRORMESSAGE,EFTTRANSACTIONID,ROUTINGNUMBER,ACCTNUMBER,MICR,ACHC
HKTYPE,SFEEAMT,CFEEAMT,RNTPAYMENTREF 
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Then, insert records into the RM Resident Charges and Credits (RESCHGCRD) Table.  
 
IF{[UPDATE]=Y,UPDATETABLE{I,RESCHGCRD,,RMBATCHID='CELL{RMBATCHID}',ITEM=CELL{COUNTER},RMPROPID='CELL{
RMPROPID}',NAMEID='CELL{NAMEID}',TRANDATE='[REPORTDATE]',CHGCODE='CF',SRCCODE='CH',DESCRPTN='Summons 
Court 
Fee',TRANAMT=CELL{AMOUNT},CHKDESC=NULL,REFNMBR=NULL,POTFLAG='N',RMRTAXID=NULL,RTAXAMT=0,INVOICE=
NULL,CASHTYPE=NULL,TAXITEM=NULL,JOBCODE=NULL,BANKID=NULL,ADJCODE=NULL,MEMOFLAG='N',MOVEND=NULL,
TRANID='CELL{TRANID}',SECCODE=NULL,ADJREASON=NULL,REVTYPE=NULL,ARCODE=NULL,ARREF=NULL,ADDLDESC=NU
LL,APPLYFLAG=NULL,SETWEBNSF=NULL,NSFLATEFEE=NULL,APPLYTAX=NULL,CHECKDATE=NULL} ,} 
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Trying it in Update Mode! 
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Now we can add a Total Segment to our report. 
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IF{[UPDATE]=Y,GRAND TOTALS for RM Batch Id TRIM{CELL{RMBATCHID}},} 
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IF{[UPDATE]=Y,SQL{UPDATE RMBTCH SET CHARGES=CELL{TOTAMT} WHERE RMBATCHID='CELL{RMBATCHID}'} , } 
 
So now we’ve identified the information in the Total Segment with a title for the Total, which includes the RM Batch Id; 
we’ve summed all amounts, and then we’ve updated the Batch with the total information so the batch can be posted. 
 

 



Advanced Report Design - RM 
 

 
 

116 
                                                                 October 19-22, 2014 | New Orleans Marriott | New 

Orleans, LA 

 
 



Advanced Report Design - RM 
 

 
 

117 
                                                                 October 19-22, 2014 | New Orleans Marriott | New 

Orleans, LA 

 
 



Advanced Report Design - RM 
 

 
 

118 
                                                                 October 19-22, 2014 | New Orleans Marriott | New 

Orleans, LA 

 
 
Now you can proceed to formatting and web enabling.  
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Now, let’s turn a query into a report. 
 
Use this query to find Old Residents, who have moved out, and a SODA does not exist, but it should. 
 
SELECT N.NAMEID, N.LASTNAME, N.FIRSTNAME, S.DATESCHD, S.DATERCRD,S.DSPDCODE FROM NAME N, SCHD S, 
RMLEASE R WHERE N.NAMEID = S.NAMEID AND N.RMPROPID=R.RMPROPID AND N.RMBLDGID=R.RMBLDGID AND 
N.UNITID=R.UNITID AND N.RMLEASE=R.RMLEASE AND N.TYPE='R' AND N.STATUS = 'O' AND R.VACATE IS NOT NULL AND 
N.NAMEID NOT IN(SELECT NAMEID FROM SODA) AND S.ACTION = 'MOVE OUT' AND S.DSPDCODE ='D' AND S.CODE='C' 
ORDER BY NAMEID 
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Again, add a Page Heading and web enable. 
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Here are a few more queries that are written that could be turned into reports: 
 
To find orphan RMLEASE records and their matching RMRECC records: 

 
SELECT * FROM RMRECC WHERE EXISTS (SELECT * FROM RMLEASE WHERE NOT EXISTS (SELECT * FROM NAME WHERE 
NAME.RMPROPID=RMLEASE.RMPROPID AND NAME.RMBLDGID=RMLEASE.RMBLDGID AND 
NAME.UNITID=RMLEASE.UNITID AND NAME.RMLEASE=RMLEASE.RMLEASE) AND 
RMLEASE.RMPROPID=RMRECC.RMPROPID AND RMLEASE.RMBLDGID=RMRECC.RMBLDGID AND 
RMLEASE.UNITID=RMRECC.UNITID AND RMLEASE.RMLEASE=RMRECC.RMLEASE) 

 

SELECT * FROM RMLEASE WHERE NOT EXISTS (SELECT * FROM NAME WHERE NAME.RMPROPID=RMLEASE.RMPROPID 
AND NAME.RMBLDGID=RMLEASE.RMBLDGID AND NAME.UNITID=RMLEASE.UNITID AND 
NAME.RMLEASE=RMLEASE.RMLEASE) 

 

Questions and Answers 

THANK YOU!! 
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Continue the Experience ………. 

 

Advanced Report Design – Accounting (W01) 

Wednesday, 9 a.m. – 10:30 a.m., Studio 1/2  

or 

SQL for CM (W08) 

Wednesday, 9 a.m. – 10:30 a.m., Mardi FGH 

 

MRI Education Services  

Any SQL Trainings 

Any WebDesign Trainings 

Advanced ReportDesign Trainings 

 

 

 


